Gerar XML Google Merchant Center e Facebook

É o Leonardo falou, eu percebi que são os mesmos, mas no facebook “leu” as categorias, no Google não… porque será?

Corrigindo o facebook tbm não leu as categorias, diz que falta o google_product_category

Na verdade eles realmente não lêm a categoria a partir da sua @Rogerio, é necessário enviar o código da taxonomia do Google, enquanto não adicionamos no painel você pode inserir diretamente no URL, por exemplo:

https://storefront.e-com.plus/products-feed.xml?store_id=1035&domain=www.kelvys.com.br&search_field=categories.slug&search_value=camisa-xadrez-masculina&set_properties={“google_product_category_id”:212}

O 212 do exemplo é referente a Vestuário e acessórios > Roupas > Camisetas e tops, se não for este o certo a referência completa (do Google mesmo) está aqui:

https://www.google.com/basepages/producttype/taxonomy-with-ids.pt-BR.txt

Ou em tabela para download aqui http://www.google.com/basepages/producttype/taxonomy-with-ids.pt-BR.xls

1 Curtida

@leonardo mas vou te falar uma coisa, o Facebook não se entende bem com isso não viu…kkk Subi um arquivo que dizia que faltavam as categorias. Depois de uns 5 min subi o mesmo e não deu erro. Vai entender né :rofl: :rofl: :rofl: Mas estou fazendo teste aqui, vou sinalizando vocês.

Depois essa taxonomia vai entrar no painel?

Sim, a ideia é que entre no painel. Só está assim de forma provisória para que consiga ter alguma forma de enviar.

Olá!
Eu desconhecia esta ferramenta de integração da loja com o facebook, fazia tudo manual… Mas ontem consegui gerar o pixel e fui lá no catálogo para tentar automatizar os produtos.
Excluí a entrada manual e… o pixel não atualizou!
Acho que preciso de ajuda!
Obrigada

Bom dia, você já gerou o XML e inseriu no Facebook criando seu novo catálogo?

@Matheus
No GMC aparecem 185 produtos. Ok!
Mas no Facebook, por ora, apenas 35 e todos com o erro: “Missing or Incorrect Data
Os identificadores universais estão ausentes: brand, gtin, mpn
Como proceder neste caso?
Obrigada

O produto precisa ter gtin ou marca se não me engano.

@Matheus eu de novo. Seguinte, enviei dois feeds, categorias distintas, conforme o tutorial, mas até agora o Google não achou os produtos. Que eu me lembre era relativamente rápido. Houve alguma mudança no feed? Seguem abaixo os dois feeds:

Faz tempo que não trabalhava com o Merchant, então não sei se houve alguma mudança. Se puderem ajudar, agradeço.

Boa tarde @roque tira as chaves da id da loja e domínio, acho que vai dar certo. O meu está assim, sem essas chaves.

https://storefront.e-com.plus/products-feed.xml?store_id=1143&domain=www.adequim.com.br&search_field=categories.slug&search_value=antimofo&set_properties={“google_product_category_id”:503738}

2 Curtidas

Boa tarde @Rogerio Como vai? Muito obrigado. É isso mesmo. Deu certo e agora só estou esperando a aprovação. Valeu mesmo! Abraço!

2 Curtidas

Imagina @roque, TMJ. Bati Kbeça com isso também :rofl: :rofl:, não sei se vai utilizar no Facebook, mas lá demora mais que no Google, mas dá certo também. Abraço

2 Curtidas

@Rogerio, tudo bem? Seguinte, com esse feed deu tudo certo para você no Google Merchant? Demorou muito tempo para aprovarem seus produtos? Digo isso, pois estou com um problema com as imagens do feed. O GMC diz que estão ausentes e por isso meus produtos estão reprovados. Falei agora com uma consultora do Google e ela disse para subir novamente os feeds. Você teve que fazer alguma coisa a mais?

Aproveitando @Matheus, essa consultora me informou que o robot.txt não está na raiz do site e disse que seria importante pro Google ter. Poderia informar a respeito, por favor?

Obrigado para ambos.

Está na raiz do site, basta acessar:

https://www.adequim.com.br/robots.txt

1 Curtida

Sobre o GMC, acessando por:

https://storefront.e-com.plus/products-feed.xml?store_id=1143&domain=www.adequim.com.br&search_field=categories.slug&search_value=antimofo&set_properties={“google_product_category_id”:503738}

A url da imagem eu consigo adicionar

Fala @roque, tudo certo e vc? Cara não tive problemas quanto a imagens não, no início tive problema com as categorias (taxonomia que não tinha), mas depois que colocou deu certo.
Você cadastrou o feed no GMC em busca programada? Na aba diagnóstico diz que o problema é com as imagens? está o alerta em vermelho? Desculpa o monte de pergunta…kkkk, mas é pra tentar ajudar.

@Matheus mas aqui “Está na raiz do site, basta acessar:” ele não tem que colocar esse link lá no Google Search Console pros robots acharem?

@Matheus, pois é. Não sei pq ela disse isso.

Bom dia @Rogerio. Tudo bem e com você? Obrigado pela ajuda. Vamos lá…

Sim, coloquei em busca programada o feed. No diagnóstico tem outras reprovações, mas acredito que não fazem sentido ou estão numa avaliação inicial. O engraçado é que se eu clico no produto no GMC, a imagem aparece. Então não entendo a razão dessa reprovação. Bom, essa consultora sugeriu de excluir esses feeds e subi-los novamente. Vou ter que fazer isso. Abaixo seguem prints para ilustrar a situação.

@Matheus te marquei apenas para você acompanhar e se tiver alguma sugestão, agradeço. Mais uma vez obrigado à todos.


Veja como a imagem está aí. Mas na lista não aparece.

As “reprovações” do GMC. :skull_and_crossbones:

1 Curtida

Bom dia @roque, justamente a imagem aparece, não faz sentido. Isso de avaliação inicial também nunca vi, sua conta no GMC é nova? Da pra enviar novamente o feed, mas também não faz sentido… Qualquer coisa fala com outro atendente hj, sempre tem respostas diferentes…kkkkkk comigo é assim… Vc viu qual é aquele problema na conta?

boa tarde fiz o processo mais não apareceu produtos no google marchant center
https://storefront.e-com.plus/products-feed.xml?store_id=1150&domain=www.bemgasto.com.br&search_field=categories.slug&search_value=antimofo&set_properties={“google_product_category_id”:1150}